Menu Search

3.2. Dependencies

The Qpid JMS client has minimal set of external dependencies.

It requires:

  • JDK 1.6 or higher. (An up to date JDK 1.7 is recommended)

  • JMS 1.1 specification (such as geronimo-jms_1.1_spec JAR)

  • Apache SLF4J (slf4j-api-x.y.z JAR)

The use of SLF4J means that application authors are free to plug in any logging framework for which an SLF4J binding exists.